$re = '/(.*?)::=(.*?)/m';
$str = 'X::=___
Y::=||
E::=ss
|___|::=zvx
Z::=_
___||::=H
W::=im
_||_::=W
_||___::=E
H::=pre
I::=empt
|z::=i
x|::=e
||pre::=ive QI
Q::=att';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);