#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\b[A-Z][a-z]+\s?\b)+$"
Local $sString = "Java Test Adfsg" & @CRLF & _
"Jaab abcdfg Abc" & @CRLF & _
"This is a Test" & @CRLF & _
"This Is A Test" & @CRLF & _
"This Is Another test" & @CRLF & _
"This Is Another Test" & @CRLF & _
"This" & @CRLF & _
"Is A New test" & @CRLF & _
"This Is Java" & @CRLF & _
"This is Java"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")