re = /^(\b[A-Z][a-z]+\s?\b)+$/m
str = 'Java Test Adfsg
Jaab abcdfg Abc
This is a Test
This Is A Test
This Is Another test
This Is Another Test
This
Is A New test
This Is Java
This is Java'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end