$re = '/^(\b[A-Z][a-z]+\s?\b)+$/m';
$str = 'Java Test Adfsg
Jaab abcdfg Abc
This is a Test
This Is A Test
This Is Another test
This Is Another Test
This
Is A New test
This Is Java
This is Java';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);