const regex = /^(\b[A-Z][a-z]+\s?\b)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\b[A-Z][a-z]+\\s?\\b)+$', 'gm')
const str = `Java Test Adfsg
Jaab abcdfg Abc
This is a Test
This Is A Test
This Is Another test
This Is Another Test
This
Is A New test
This Is Java
This is Java`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}