package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\b[A-Z][a-z]+\s?\b)+$`)
var str = `Java Test Adfsg
Jaab abcdfg Abc
This is a Test
This Is A Test
This Is Another test
This Is Another Test
This
Is A New test
This Is Java
This is Java`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}