import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\b[A-Z][a-z]+\\s?\\b)+$";
final String string = "Java Test Adfsg\n"
+ "Jaab abcdfg Abc\n"
+ "This is a Test\n"
+ "This Is A Test\n"
+ "This Is Another test\n"
+ "This Is Another Test\n"
+ "This\n"
+ "Is A New test\n"
+ "This Is Java\n"
+ "This is Java";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}