use strict;
my $str = 'Java Test Adfsg
Jaab abcdfg Abc
This is a Test
This Is A Test
This Is Another test
This Is Another Test
This
Is A New test
This Is Java
This is Java';
my $regex = qr/^(\b[A-Z][a-z]+\s?\b)+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}