using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\d)\s*\.\d+\.";
string substitution = @".";
string input = @"remove 1 from .1.
XYZ is a student.2. XYZ is a boy.3. XYZ is smart.
This is a test value 1.1.
127.0.0.1";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}