re = /(?<!\d)\s*\.\d+\./m
str = 'remove 1 from .1.
XYZ is a student.2. XYZ is a boy.3. XYZ is smart.
This is a test value 1.1.
127.0.0.1'
subst = '.'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result