const regex = new RegExp('(?<!\\d)\\s*\\.\\d+\\.', 'gm')
const str = `remove 1 from .1.
XYZ is a student.2. XYZ is a boy.3. XYZ is smart.
This is a test value 1.1.
127.0.0.1`;
const subst = `.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);