import re
regex = re.compile(r"(?<!\d)\s*\.\d+\.", flags=re.MULTILINE)
test_str = ("remove 1 from .1.\n"
"XYZ is a student.2. XYZ is a boy.3. XYZ is smart.\n"
"This is a test value 1.1.\n\n"
"127.0.0.1")
subst = "."
result = regex.sub(subst, test_str)
if result:
print(result)