import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\d)\\s*\\.\\d+\\.";
final String string = "remove 1 from .1.\n"
+ "XYZ is a student.2. XYZ is a boy.3. XYZ is smart.\n"
+ "This is a test value 1.1.\n\n"
+ "127.0.0.1";
final String subst = ".";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}