# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:<p>|\G(?!^))(?:(?!<\/p>).)*)\s+/\1/gm;t' <<< "<p>Fie pentru a păstra prospețimea anumitor culori (ex. odinioară, ullraniarinul. Text.
Altădată se folosea usturoiul, deoarece conține și un ulei esențial, rare aderă prin dizolvarea la suprafață a grăsimilor și lotodală un mucegaiul cleios, sensibil la apă.</p>"