import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:<p>|\\G(?!^))(?:(?!</p>).)*)\\s+";
final String string = "<p>Fie pentru a păstra prospețimea anumitor culori (ex. odinioară, ullraniarinul. Text.\n\n"
+ " \n\n"
+ " \n\n"
+ "Altădată se folosea usturoiul, deoarece conține și un ulei esențial, rare aderă prin dizolvarea la suprafață a grăsimilor și lotodală un mucegaiul cleios, sensibil la apă.</p>";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}