re = /((?:<p>|\G(?!^))(?:(?!<\/p>).)*)\s+/m
str = '<p>Fie pentru a păstra prospețimea anumitor culori (ex. odinioară, ullraniarinul. Text.
Altădată se folosea usturoiul, deoarece conține și un ulei esențial, rare aderă prin dizolvarea la suprafață a grăsimilor și lotodală un mucegaiul cleios, sensibil la apă.</p>'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result