using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:<p>|\G(?!^))(?:(?!</p>).)*)\s+";
string substitution = @"\1";
string input = @"<p>Fie pentru a păstra prospețimea anumitor culori (ex. odinioară, ullraniarinul. Text.
Altădată se folosea usturoiul, deoarece conține și un ulei esențial, rare aderă prin dizolvarea la suprafață a grăsimilor și lotodală un mucegaiul cleios, sensibil la apă.</p>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}