import Foundation
let pattern = #"((?:<p>|\G(?!^))(?:(?!</p>).)*)\s+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<p>Fie pentru a păstra prospețimea anumitor culori (ex. odinioară, ullraniarinul. Text.
Altădată se folosea usturoiul, deoarece conține și un ulei esențial, rare aderă prin dizolvarea la suprafață a grăsimilor și lotodală un mucegaiul cleios, sensibil la apă.</p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)