#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bsensitivity\s*"(\d+)""
Local $sString = "zoom_sensitivity "2"" & @CRLF & _
"sensitivity "99"" & @CRLF & _
"m_rawinput "0"" & @CRLF & _
"m_righthand "0"" & @CRLF & _
"" & @CRLF & _
"also with different spacing:" & @CRLF & _
"" & @CRLF & _
"sensitivity"99"m_rawinput"0"zoom_sensitivity"2"m_righthand"0"" & @CRLF & _
"" & @CRLF & _
"another example:" & @CRLF & _
"" & @CRLF & _
"sensitivity"99" m_rawinput "0"" & @CRLF & _
"m_righthand "0"" & @CRLF & _
"zoom_sensitivity"2""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")