package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bsensitivity\s*"(\d+)"`)
var str = `zoom_sensitivity "2"
sensitivity "99"
m_rawinput "0"
m_righthand "0"
also with different spacing:
sensitivity"99"m_rawinput"0"zoom_sensitivity"2"m_righthand"0"
another example:
sensitivity"99" m_rawinput "0"
m_righthand "0"
zoom_sensitivity"2"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}