re = /\bsensitivity\s*"(\d+)"/m
str = 'zoom_sensitivity "2"
sensitivity "99"
m_rawinput "0"
m_righthand "0"
also with different spacing:
sensitivity"99"m_rawinput"0"zoom_sensitivity"2"m_righthand"0"
another example:
sensitivity"99" m_rawinput "0"
m_righthand "0"
zoom_sensitivity"2"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end