import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bsensitivity\\s*\"(\\d+)\"";
final String string = "zoom_sensitivity \"2\"\n"
+ "sensitivity \"99\"\n"
+ "m_rawinput \"0\"\n"
+ "m_righthand \"0\"\n\n"
+ "also with different spacing:\n\n"
+ "sensitivity\"99\"m_rawinput\"0\"zoom_sensitivity\"2\"m_righthand\"0\"\n\n"
+ "another example:\n\n"
+ "sensitivity\"99\" m_rawinput \"0\"\n"
+ "m_righthand \"0\"\n"
+ "zoom_sensitivity\"2\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}