use strict;
my $str = 'zoom_sensitivity "2"
sensitivity "99"
m_rawinput "0"
m_righthand "0"
also with different spacing:
sensitivity"99"m_rawinput"0"zoom_sensitivity"2"m_righthand"0"
another example:
sensitivity"99" m_rawinput "0"
m_righthand "0"
zoom_sensitivity"2"';
my $regex = qr/\bsensitivity\s*"(\d+)"/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}