# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*randomwebsite\.com.*)lowquality(.*\.png)/$1highquality$2/gm;t' <<< "https://randomwebsite.com/gallery/randomstring124/lowquality/imagename.png"