import re
regex = re.compile(r"(.*randomwebsite\.com.*)lowquality(.*\.png)", flags=re.MULTILINE)
test_str = "https://randomwebsite.com/gallery/randomstring124/lowquality/imagename.png"
subst = "$1highquality$2"
result = regex.sub(subst, test_str)
if result:
print(result)