re = /(.*randomwebsite\.com.*)lowquality(.*\.png)/m
str = 'https://randomwebsite.com/gallery/randomstring124/lowquality/imagename.png'
subst = '$1highquality$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result