$re = '/(.*randomwebsite\.com.*)lowquality(.*\.png)/m';
$str = 'https://randomwebsite.com/gallery/randomstring124/lowquality/imagename.png';
$subst = "$1highquality$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;