// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*randomwebsite\.com.*)lowquality(.*\.png)").unwrap();
let string = "https://randomwebsite.com/gallery/randomstring124/lowquality/imagename.png";
let substitution = "$1highquality$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}