#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((([a-z0-9]+[\-]{0,1})+[a-z0-9]+?\.)+[a-z0-9][a-z0-9|\-]+[a-z0-9])@([a-z0-9]+[\-|\.]{0,1}[a-z0-9]+)+(.[a-z0-9]{2,})+$"
Local $sString = "m-0-o.bfe-nfk@s-ugd-og.gg-gm-ain.com.pl" & @CRLF & _
"" & @CRLF & _
"wfff-ef-ff.mi-ki.fi-ki.miki@dns1-su-ddd.o-ma.in.dom-ain.kkk" & @CRLF & _
"" & @CRLF & _
"max-io.be-nko@sub-dom-ain.dom-ain.com.pl" & @CRLF & _
"" & @CRLF & _
"#ver. 6" & @CRLF & _
"^((([a-z0-9]+[\-]{0,1})+[a-z0-9]+?\.)+[a-z0-9][a-z0-9|\-]+[a-z0-9])@([a-z0-9]+[\-|\.]{0,1}[a-z0-9])+(.[a-z0-9]{2,})+$" & @CRLF & _
"" & @CRLF & _
"#ver. 5" & @CRLF & _
"^([a-z0-9][a-z0-9|\-]+[a-z0-9]{1,}?\.)+[a-z0-9|\-]+[a-z0-9]@([a-z0-9][a-z0-9|\-]+?\.[a-z0-9|\-]+[a-z0-9](.[a-z0-9]{2,})+)$" & @CRLF & _
"" & @CRLF & _
"#ver. 4" & @CRLF & _
"^[\w][a-z0-9|\-]+?\.[a-z0-9|\-]+[\w]@([\w][a-z0-9|\-]+?\.[a-z0-9|\-]+[\w](.[a-z0-9]{2,})+)$" & @CRLF & _
"" & @CRLF & _
"# ver. 3" & @CRLF & _
"^[a-z0-9\-\.]+@([\w][a-z0-9|\-]+?\.[a-z0-9|\-]+[\w](.[a-z0-9]{2,})+)$" & @CRLF & _
"" & @CRLF & _
"#ver. 2" & @CRLF & _
"^[a-z0-9\-\.]+@[a-z0-9|\-]+?\.[a-z0-9|\-]+(.[a-z0-9]{2,})+$" & @CRLF & _
"" & @CRLF & _
"#ver. 1" & @CRLF & _
"^([\w\.\-]+)@([\w\-]+)((\.(\w){2,3})+)$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")