import Foundation
let pattern = #"^((([a-z0-9]+[\-]{0,1})+[a-z0-9]+?\.)+[a-z0-9][a-z0-9|\-]+[a-z0-9])@([a-z0-9]+[\-|\.]{0,1}[a-z0-9]+)+(.[a-z0-9]{2,})+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
m-0-o.bfe-nfk@s-ugd-og.gg-gm-ain.com.pl
wfff-ef-ff.mi-ki.fi-ki.miki@dns1-su-ddd.o-ma.in.dom-ain.kkk
max-io.be-nko@sub-dom-ain.dom-ain.com.pl
#ver. 6
^((([a-z0-9]+[\-]{0,1})+[a-z0-9]+?\.)+[a-z0-9][a-z0-9|\-]+[a-z0-9])@([a-z0-9]+[\-|\.]{0,1}[a-z0-9])+(.[a-z0-9]{2,})+$
#ver. 5
^([a-z0-9][a-z0-9|\-]+[a-z0-9]{1,}?\.)+[a-z0-9|\-]+[a-z0-9]@([a-z0-9][a-z0-9|\-]+?\.[a-z0-9|\-]+[a-z0-9](.[a-z0-9]{2,})+)$
#ver. 4
^[\w][a-z0-9|\-]+?\.[a-z0-9|\-]+[\w]@([\w][a-z0-9|\-]+?\.[a-z0-9|\-]+[\w](.[a-z0-9]{2,})+)$
# ver. 3
^[a-z0-9\-\.]+@([\w][a-z0-9|\-]+?\.[a-z0-9|\-]+[\w](.[a-z0-9]{2,})+)$
#ver. 2
^[a-z0-9\-\.]+@[a-z0-9|\-]+?\.[a-z0-9|\-]+(.[a-z0-9]{2,})+$
#ver. 1
^([\w\.\-]+)@([\w\-]+)((\.(\w){2,3})+)$
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)