import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((([a-z0-9]+[\\-]{0,1})+[a-z0-9]+?\\.)+[a-z0-9][a-z0-9|\\-]+[a-z0-9])@([a-z0-9]+[\\-|\\.]{0,1}[a-z0-9]+)+(.[a-z0-9]{2,})+$";
final String string = "m-0-o.bfe-nfk@s-ugd-og.gg-gm-ain.com.pl\n\n"
+ "wfff-ef-ff.mi-ki.fi-ki.miki@dns1-su-ddd.o-ma.in.dom-ain.kkk\n\n"
+ "max-io.be-nko@sub-dom-ain.dom-ain.com.pl\n\n"
+ "#ver. 6\n"
+ "^((([a-z0-9]+[\\-]{0,1})+[a-z0-9]+?\\.)+[a-z0-9][a-z0-9|\\-]+[a-z0-9])@([a-z0-9]+[\\-|\\.]{0,1}[a-z0-9])+(.[a-z0-9]{2,})+$\n\n"
+ "#ver. 5\n"
+ "^([a-z0-9][a-z0-9|\\-]+[a-z0-9]{1,}?\\.)+[a-z0-9|\\-]+[a-z0-9]@([a-z0-9][a-z0-9|\\-]+?\\.[a-z0-9|\\-]+[a-z0-9](.[a-z0-9]{2,})+)$\n\n"
+ "#ver. 4\n"
+ "^[\\w][a-z0-9|\\-]+?\\.[a-z0-9|\\-]+[\\w]@([\\w][a-z0-9|\\-]+?\\.[a-z0-9|\\-]+[\\w](.[a-z0-9]{2,})+)$\n\n"
+ "# ver. 3\n"
+ "^[a-z0-9\\-\\.]+@([\\w][a-z0-9|\\-]+?\\.[a-z0-9|\\-]+[\\w](.[a-z0-9]{2,})+)$\n\n"
+ "#ver. 2\n"
+ "^[a-z0-9\\-\\.]+@[a-z0-9|\\-]+?\\.[a-z0-9|\\-]+(.[a-z0-9]{2,})+$\n\n"
+ "#ver. 1\n"
+ "^([\\w\\.\\-]+)@([\\w\\-]+)((\\.(\\w){2,3})+)$";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}