// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((([a-z0-9]+[\-]{0,1})+[a-z0-9]+?\.)+[a-z0-9][a-z0-9|\-]+[a-z0-9])@([a-z0-9]+[\-|\.]{0,1}[a-z0-9]+)+(.[a-z0-9]{2,})+$").unwrap();
let string = "m-0-o.bfe-nfk@s-ugd-og.gg-gm-ain.com.pl
wfff-ef-ff.mi-ki.fi-ki.miki@dns1-su-ddd.o-ma.in.dom-ain.kkk
max-io.be-nko@sub-dom-ain.dom-ain.com.pl
#ver. 6
^((([a-z0-9]+[\\-]{0,1})+[a-z0-9]+?\\.)+[a-z0-9][a-z0-9|\\-]+[a-z0-9])@([a-z0-9]+[\\-|\\.]{0,1}[a-z0-9])+(.[a-z0-9]{2,})+$
#ver. 5
^([a-z0-9][a-z0-9|\\-]+[a-z0-9]{1,}?\\.)+[a-z0-9|\\-]+[a-z0-9]@([a-z0-9][a-z0-9|\\-]+?\\.[a-z0-9|\\-]+[a-z0-9](.[a-z0-9]{2,})+)$
#ver. 4
^[\\w][a-z0-9|\\-]+?\\.[a-z0-9|\\-]+[\\w]@([\\w][a-z0-9|\\-]+?\\.[a-z0-9|\\-]+[\\w](.[a-z0-9]{2,})+)$
# ver. 3
^[a-z0-9\\-\\.]+@([\\w][a-z0-9|\\-]+?\\.[a-z0-9|\\-]+[\\w](.[a-z0-9]{2,})+)$
#ver. 2
^[a-z0-9\\-\\.]+@[a-z0-9|\\-]+?\\.[a-z0-9|\\-]+(.[a-z0-9]{2,})+$
#ver. 1
^([\\w\\.\\-]+)@([\\w\\-]+)((\\.(\\w){2,3})+)$";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}