$re = '/^((([a-z0-9]+[\-]{0,1})+[a-z0-9]+?\.)+[a-z0-9][a-z0-9|\-]+[a-z0-9])@([a-z0-9]+[\-|\.]{0,1}[a-z0-9]+)+(.[a-z0-9]{2,})+$/m';
$str = 'm-0-o.bfe-nfk@s-ugd-og.gg-gm-ain.com.pl
wfff-ef-ff.mi-ki.fi-ki.miki@dns1-su-ddd.o-ma.in.dom-ain.kkk
max-io.be-nko@sub-dom-ain.dom-ain.com.pl
#ver. 6
^((([a-z0-9]+[\\-]{0,1})+[a-z0-9]+?\\.)+[a-z0-9][a-z0-9|\\-]+[a-z0-9])@([a-z0-9]+[\\-|\\.]{0,1}[a-z0-9])+(.[a-z0-9]{2,})+$
#ver. 5
^([a-z0-9][a-z0-9|\\-]+[a-z0-9]{1,}?\\.)+[a-z0-9|\\-]+[a-z0-9]@([a-z0-9][a-z0-9|\\-]+?\\.[a-z0-9|\\-]+[a-z0-9](.[a-z0-9]{2,})+)$
#ver. 4
^[\\w][a-z0-9|\\-]+?\\.[a-z0-9|\\-]+[\\w]@([\\w][a-z0-9|\\-]+?\\.[a-z0-9|\\-]+[\\w](.[a-z0-9]{2,})+)$
# ver. 3
^[a-z0-9\\-\\.]+@([\\w][a-z0-9|\\-]+?\\.[a-z0-9|\\-]+[\\w](.[a-z0-9]{2,})+)$
#ver. 2
^[a-z0-9\\-\\.]+@[a-z0-9|\\-]+?\\.[a-z0-9|\\-]+(.[a-z0-9]{2,})+$
#ver. 1
^([\\w\\.\\-]+)@([\\w\\-]+)((\\.(\\w){2,3})+)$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);