import re
regex = re.compile(r"^((([a-z0-9]+[\-]{0,1})+[a-z0-9]+?\.)+[a-z0-9][a-z0-9|\-]+[a-z0-9])@([a-z0-9]+[\-|\.]{0,1}[a-z0-9]+)+(.[a-z0-9]{2,})+$", flags=re.MULTILINE)
test_str = ("m-0-o.bfe-nfk@s-ugd-og.gg-gm-ain.com.pl\n\n"
"wfff-ef-ff.mi-ki.fi-ki.miki@dns1-su-ddd.o-ma.in.dom-ain.kkk\n\n"
"max-io.be-nko@sub-dom-ain.dom-ain.com.pl\n\n"
"#ver. 6\n"
"^((([a-z0-9]+[\\-]{0,1})+[a-z0-9]+?\\.)+[a-z0-9][a-z0-9|\\-]+[a-z0-9])@([a-z0-9]+[\\-|\\.]{0,1}[a-z0-9])+(.[a-z0-9]{2,})+$\n\n"
"#ver. 5\n"
"^([a-z0-9][a-z0-9|\\-]+[a-z0-9]{1,}?\\.)+[a-z0-9|\\-]+[a-z0-9]@([a-z0-9][a-z0-9|\\-]+?\\.[a-z0-9|\\-]+[a-z0-9](.[a-z0-9]{2,})+)$\n\n"
"#ver. 4\n"
"^[\\w][a-z0-9|\\-]+?\\.[a-z0-9|\\-]+[\\w]@([\\w][a-z0-9|\\-]+?\\.[a-z0-9|\\-]+[\\w](.[a-z0-9]{2,})+)$\n\n"
"# ver. 3\n"
"^[a-z0-9\\-\\.]+@([\\w][a-z0-9|\\-]+?\\.[a-z0-9|\\-]+[\\w](.[a-z0-9]{2,})+)$\n\n"
"#ver. 2\n"
"^[a-z0-9\\-\\.]+@[a-z0-9|\\-]+?\\.[a-z0-9|\\-]+(.[a-z0-9]{2,})+$\n\n"
"#ver. 1\n"
"^([\\w\\.\\-]+)@([\\w\\-]+)((\\.(\\w){2,3})+)$")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")