# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*\/countrycode(\/[^\/]+\.\w+)$/$1/gm;t' <<< "www.websitename/countrycode/websitename/contact/thank-you/whitepaper/countrycode/whitepapername.pdf"