#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.*/countrycode(/[^/]+\.\w+)$"
Local $sString = "www.websitename/countrycode/websitename/contact/thank-you/whitepaper/countrycode/whitepapername.pdf"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)