import Foundation
let pattern = #"^.*/countrycode(/[^/]+\.\w+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"www.websitename/countrycode/websitename/contact/thank-you/whitepaper/countrycode/whitepapername.pdf"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)