const regex = new RegExp('^.*/countrycode(/[^/]+\\.\\w+)$', 'gm')
const str = `www.websitename/countrycode/websitename/contact/thank-you/whitepaper/countrycode/whitepapername.pdf`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);