using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*/countrycode(/[^/]+\.\w+)$";
string substitution = @"$1";
string input = @"www.websitename/countrycode/websitename/contact/thank-you/whitepaper/countrycode/whitepapername.pdf";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}