use strict;
my $str = 'www.websitename/countrycode/websitename/contact/thank-you/whitepaper/countrycode/whitepapername.pdf';
my $regex = qr`^.*/countrycode(/[^/]+\.\w+)$`mp;
my $subst = '$1';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";