$re = '`^.*/countrycode(/[^/]+\.\w+)$`m';
$str = 'www.websitename/countrycode/websitename/contact/thank-you/whitepaper/countrycode/whitepapername.pdf';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;