#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(\[trace-[0-9]+\].*?<\/(?:reply|request)>)"
Local $sString = "[trace-123] <request>This is a log line</request>" & @CRLF & _
"[trace-124] <reply>This is another log line" & @CRLF & _
"" & @CRLF & _
"this is part of "[trace-124]" still.</reply>" & @CRLF & _
"[trace-125] <request>final log line.</request>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")