// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)(\[trace-[0-9]+\].*?<\/(?:reply|request)>)").unwrap();
let string = "[trace-123] <request>This is a log line</request>
[trace-124] <reply>This is another log line
this is part of \"[trace-124]\" still.</reply>
[trace-125] <request>final log line.</request>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}