package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(\[trace-[0-9]+\].*?<\/(?:reply|request)>)`)
var str = `[trace-123] <request>This is a log line</request>
[trace-124] <reply>This is another log line
this is part of "[trace-124]" still.</reply>
[trace-125] <request>final log line.</request>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}