import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\[trace-[0-9]+\\].*?<\\/(?:reply|request)>)";
final String string = "[trace-123] <request>This is a log line</request>\n"
+ "[trace-124] <reply>This is another log line\n\n"
+ "this is part of \"[trace-124]\" still.</reply>\n"
+ "[trace-125] <request>final log line.</request>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}