const regex = /(\[trace-[0-9]+\].*?<\/(?:reply|request)>)/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\[trace-[0-9]+\\].*?<\\\/(?:reply|request)>)', 'gs')
const str = `[trace-123] <request>This is a log line</request>
[trace-124] <reply>This is another log line
this is part of "[trace-124]" still.</reply>
[trace-125] <request>final log line.</request>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}