re = /(\[trace-[0-9]+\].*?<\/(?:reply|request)>)/
str = '[trace-123] <request>This is a log line</request>
[trace-124] <reply>This is another log line
this is part of "[trace-124]" still.</reply>
[trace-125] <request>final log line.</request>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end