using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[trace-[0-9]+\].*?<\/(?:reply|request)>)";
string input = @"[trace-123] <request>This is a log line</request>
[trace-124] <reply>This is another log line
this is part of ""[trace-124]"" still.</reply>
[trace-125] <request>final log line.</request>";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}