#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\d*(?:\.\d+)?)[\.\d]*$"
Local $sString = "0.2" & @CRLF & _
"2.2" & @CRLF & _
"2.0" & @CRLF & _
".2" & @CRLF & _
"2.2." & @CRLF & _
"0.2." & @CRLF & _
"2.2.2.2.2" & @CRLF & _
"0.2.2.2" & @CRLF & _
".22.2.2.2" & @CRLF & _
"2222.22" & @CRLF & _
"2." & @CRLF & _
"222." & @CRLF & _
"123.12a"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)