import Foundation
let pattern = #"^(\d*(?:\.\d+)?)[\.\d]*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0.2
2.2
2.0
.2
2.2.
0.2.
2.2.2.2.2
0.2.2.2
.22.2.2.2
2222.22
2.
222.
123.12a
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)